Drivers

SCCM Surface Pro 4 Domain Join Issues (Windows 10)

Afternoon, Had some fun and games whilst onsite with SCCM, Windows 10 and Surface Pro 4’s (SP4). I captured my reference image using MDT, downloaded the drivers from Microsoft, imported everything into SCCM, configured the task sequence and then the trouble started … I couldn’t find the Ethernet drivers for the SP4 so instead I used the Ethernet drivers for the Pro 3 to allow my boot image to start working. After the boot issues were overcome, the build finishes but the device wouldn’t domain join. On some occasions, the Ethernet dongle for the surface wouldn’t turn back on after a reboot and other times it did … So I managed to track down all the correct drivers I needed and re-created the boot.wim to get back on track, this time the Ethernet dongle stayed up after the reboots and I hoped that this would fix the domain join issues and it didn’t…

SCCM 2012 R2 – Driver Packages (Specific driver packages to specific devices)

Players, When it comes to driver packages and deploying Windows to multiple hardware variants using the same task sequence, every man and his dog has a way of doing it. Some of us like to be precise and other don’t mind how this is configured as long as all the drivers are on the DP and they get onto machines one way or another … So, lets pretend that we want to be a little more specific with drivers and we don’t like “Auto Deploy” as we have taken the time to create individual driver packages for each hardware variant. Here is some guidance on how to deploy specific driver packages to specific devices via the task sequence. 1. We need to know what the model name is for the specific machine/s first. So open command prompt (or PowerShell if you want to look cool) and type WMIC Computersystem GET Model you should get…