Surface Pro 4 – USB boot issue without keyboard

Surface Pro 4 – USB boot issue without keyboard
Rate this post

Hi All,

I’m currently engaged in a Windows 10 migration project. Customer is trying to remove all the infrastructure from the locations and because of this, there is no DP on the sites. A content provider like 1E Nomad would be a great solution for this customer, however, at the moment, they preferred to use an USB solution.

The task sequence has been created to support this scenario as well as i have created some custom scripts to help with the deployment, so the deployment needs a network (not wifi) and USB. It has been great, until i had to test the deployment on a Surface Pro.

As you can imagine, Surface Pro 4 only have 1 USB port, so how can I achieve the deployment on this scenario? if i use the USB port for the TS, i don’t have network. If i use it for the network, i need to pxe and this is not what the customer wants (at the moment).

So, i decided to use a USB Hub. On my 1st test, i plugged the usb hub, plugged the usb on the hub as well as the network usb adapter and booted surface pro (pressing the power button and volume down). it worked great, i was able to boot. so i turned the device off (as i needed to update the usb task sequence) and removed the keyboard.

next day, i tried with the new USB boot and nothing happen, i wasn’t able to do anything, and this has been going on for 2 days. today, i decided to plug the keyboard back so i could do some troubleshooting and for my surprise, i was able to boot from the usb.

removed the keyboard and it stopped work.

interesting outcome, so i learned to use the surface pro 4 with usb boot, you need to have a keyboard 🙂

hope this will help you out.

Tags:

Recent Posts

Comments are closed.
%d bloggers like this: